AWS DNS Outage
Incident Report for Flow
Resolved
Our hosting provider has stated they have resolved their issues. To quote,

>Between 10:30 AM and 6:30 PM PDT, we experienced intermittent errors with resolution of some AWS DNS names

If you are still experiencing issues, please don't hesitate to reach out to help@getflow.com
Posted Oct 23, 2019 - 13:07 UTC
Investigating
Our upstream hosting provider, Amazon Web Services (AWS), is currently experiencing intermittent problems with their DNS infrastructure. This may manifest in intermittent errors with various functions within Flow, especially surrounding file uploads and attachments. We are closely monitoring the situation and will provide updates as the situation develops.
Posted Oct 22, 2019 - 20:10 UTC
This incident affected: Flow API and Flow Chat.