New user invitation link failure
Incident Report for Flow
Resolved
This incident has been resolved.
Posted 10 months ago. Jan 12, 2017 - 22:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Jan 12, 2017 - 20:56 UTC
Identified
Invite links for new Flow users are not working due to issues with our downstream provider. Please contact Flow Support for any questions.
Posted 10 months ago. Jan 12, 2017 - 18:57 UTC