Chat connectivity issues
Incident Report for Flow
Resolved
This incident has been resolved.
Posted Jun 20, 2016 - 07:50 PDT
Investigating
We are currently investigating this issue.
Posted Jun 20, 2016 - 07:43 PDT