Delayed email notifications
Incident Report for Flow
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 12, 2017 - 00:04 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 2 years ago. Jan 11, 2017 - 23:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted almost 2 years ago. Jan 11, 2017 - 23:03 UTC