Delayed email notifications
Incident Report for Flow
Resolved
This incident has been resolved.
Posted Jun 21, 2016 - 20:03 PDT
Identified
Currently observing issues with outgoing mail delivery. Notifications, invites and confirmation emails may be delayed.
Posted Jun 21, 2016 - 09:30 PDT