Chat connectivity issues
Incident Report for Flow
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 18, 2016 - 17:49 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Jul 18, 2016 - 17:38 UTC