Chat connectivity issues
Incident Report for Flow
Resolved
This incident has been resolved.
Posted Jun 13, 2016 - 09:37 PDT
Investigating
We're investigating chat connectivity issues.
Posted Jun 13, 2016 - 08:59 PDT