Provider Outage
Incident Report for Flow
Resolved
The upstream provider has resolved their situation. Access to Flow should be working normally once again.
Posted 5 months ago. Mar 02, 2018 - 23:04 UTC
Identified
While Flow's infrastructure is operational, an upstream provider[1] is experiencing connectivity problems to North American internet providers. You may be unable to connect to Flow Web, Desktop, and Mobile apps during this incident.

[1]: http://status.aws.amazon.com/
Posted 5 months ago. Mar 02, 2018 - 22:13 UTC