Delayed email notifications
Incident Report for Flow
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 18, 2016 - 17:39 UTC
Identified
One of our downstream service provider is having technical difficulties and it has affected our email notifications.
Posted over 1 year ago. Jul 18, 2016 - 16:58 UTC